Our Blog

Let us find tech solutions together

Dec 06

Fixing regeneratorRuntime error integrating redux-saga

By Andrew Lombardi - @kinabalu | Comments

 

While integrating redux-saga an annoying little error may pop up in the console.

1
Uncaught ReferenceError: regeneratorRuntime is not defined

It took a bit of research to figure out why, and it shouldn’t have since the notice is listed in the README for redux-saga. Most browsers do not support ES2015 generators, so require using a polyfill.

I am going to assume usage of the react-slingshot bootstrap as mentioned in a previous post about usable bootstrap with react-slingshot.

Add the import for babel-polyfill prior to importing redux-saga to the src/store/configureStore.js.

1
2
import 'babel-polyfill';
import createSagaMiddleware from 'redux-saga';

Enjoy.

Join the Mystic Team

If articles like this, and technology that we discuss on the blog is interesting to you, let us know